Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2026 - 06:00 BST
Scheduled
Following todays Nasstar infrastructure issue, we have been notified of essential maintenance being undertaken tomorrow morning by Nasstar engineers.
We have been advised this will not affect our clients, however we wil be implementing diverts during the maintenance window to protect service.
We will also use the maintenance window while diverst are in effect to push out updates to our VCC platform, to minimise further disruption to our clients at a later date.
Posted Jun 09, 2026 - 12:12 BST
This scheduled maintenance affected: Virtual Contact Centre (User Interface, Voice Ingress) and Telecoms/Data Network.