Hubbub Softphones Unavailable

Incident Report for Call Handling System

Resolved

Service has been restored. Our IP team is closely monitoriong AWS performance.

If you logged in with mobiles or landline phones you may now revert to Hubbub VoIP softphones.

We will liaise with AWS and issue an RCA on this incident as soon as we have a full report on the cause. Our aplogies for any inconvenience this brief impact caused.
Posted May 01, 2026 - 14:29 BST

Investigating

We are experiencing an outage at Amazon Web Services that is affecting our Hubbub VoiP Softphones.

Please login with a mobile phone or a landline number to continue receiving calls. We are rasing this as a P1 with AWS and will update as soon as possible.
Posted May 01, 2026 - 14:07 BST
This incident affected: Hubbub Voip Platform.