Partial Nasstar Network Outage - 03rd April 2025

Incident Report for Call Handling System

Resolved

Nasstar have resolved their incident and we have re-routed traffic back to normal operations.

If you believe you have calls or agents stuck in status, please dont hesitate to contact us on 0333 321 0888.
Posted Apr 03, 2025 - 16:31 BST

Identified

We are aware that Nasstar is just suffered a partial outage on their IP Network. This outage affected call delivery from approximately 15:30. This would have casused some outbound calls to fail, some callers stuck in queues or agents possibly stuck in status.

As this is not a complete outage we were able to divert traffic to unaffected routes from 16:00.

if you have any agents unable to change status or calls apparently stuck in the queue (callers waiting but no calls coming through) please contact us on 0333 321 0888.
Posted Apr 03, 2025 - 16:23 BST
This incident affected: Telecoms/Data Network.