Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 05:00 BST
Scheduled
We are undertaking essential maintenance on our web services including updates to our security protocols.
This maintenance window will require our web services to be taken offline for up to 10 minutes. This includes VCC Agent and Manager Pages, and in-browser Hubbub VoIP Softphones which will be unreachable during the update.
Calls will still be delivered to logged in Available agents, but VCC users will not be able to update their VCC status during the planned downtime.
We strongly recommend that any VCC users who are expecting to receive calls during this period, set their work phone to a mobile or geographic number instead of their Hubbub VoIP softphone for the duration of the maintenance window. This will prevent any impact on ongoing calls when web services are taken offline.
If you have any concerns about this maintenance, please don’t hesitate to contact clientsupport@callhandling.co.uk or call us on 0333 321 0888.
Posted Apr 11, 2025 - 10:42 BST
This scheduled maintenance affected: Authentication, Online Statistics, Call Recording and Virtual Contact Centre (User Interface, WebChat Ingress/Egress, Email Ingress, AI Chat Bot, SMS Egress, Manager Pro UI, Data Capture, Wall Boards).